My legacy products won't install for EDIUS 8. What can I do?

Our legacy product line was discontinued before EDIUS 8 was released.  Therefore, legacy plugins will not install for EDIUS 8 automatically. However, you can get them working with these steps:

  1. Reboot your system
  2. Run the installers for your legacy products
  3. Download and extract this .zip folder: www.newbluefx.com/downloads/Support/EDIUS_x64_legacy_plugins.zip
  4. Once extracted, copy the relevant product folders and paste them in C:\Program Files\Grass Valley\EDIUS 8\PlugIn\NewBlueFX
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

1 comment
  • Thanks a lot for this solution very usefull indead.
    It's perfect for the transitions, but for Elements, after having bought Essential 1 to 7, I moved to Element " Ultimate, Essentials 3 Ultimate and Filters 3 Ultimate, including a new version of the stabilizer. Unfortunately, I cannot find the corresponding plug'ins in the zip folder.
    Is it possible to get them?
    Thanks a lot in advance.
    Daniel

Please sign in to leave a comment.

Powered by Zendesk